Kontakt
Einfach Suchbegriff eingeben und Enter drücken
Abbrechen

Meine NEOS-Website findet keine Grafiken und CSS, wenn ich über IPv4 zugreife, obwohl über IPv6 alles funktioniert

NEOS versucht bei Zugriff über Nicht-Standard-Portnummern automatisch die generierten Links so anzupassen, dass diese ebenfalls diese Portnummer verwenden. Da wir Zugriffe per IPv4 über den vorgelagerten Proxy auf abweichende Portnummern zum Webserver leiten, führt das zu Problemen. Zur Abhilfe kann man dem Webserver sagen, dass er die tatsächliche Portnummer ignorieren und bei SSL einfach fest 443 annehmen soll.

Bei neueren Installationen haben wir das mit folgendem Abschnitt am Ende von /usr/local/etc/nginx/include/neos.conf gelöst:

location ~ \.php$ {
  include /usr/local/etc/nginx/fastcgi_params;
  try_files $uri =404;
  fastcgi_pass unix:/var/run/php-fpm/php-fpm.socket;
  fastcgi_index index.php;
  fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
  fastcgi_param PATH_INFO $fastcgi_path_info;
  fastcgi_param FLOW_REWRITEURLS 1;
  fastcgi_param FLOW_CONTEXT Production/Local;
  fastcgi_param X-Forwarded-For $proxy_add_x_forwarded_for;
  fastcgi_param X-Forwarded-Port $proxy_port;
  fastcgi_param SERVER_NAME $http_host;
  fastcgi_param SERVER_PORT 443;
  fastcgi_split_path_info ^(.+\.php)(.*)$;
  fastcgi_read_timeout 300;
  fastcgi_buffer_size 128k;
  fastcgi_buffers 256 16k;
  fastcgi_busy_buffers_size 256k;
  fastcgi_temp_file_write_size 256k;
}

Bei älteren Installationen fehlt in der Datei die Zeile "fastcgi_param SERVER_PORT 443;". Diese Zeile muss ergänzt werden und nginx einmal mit "service nginx restart" durchgestartet werden.